Getting Started

Welcome to MPower! MPower is a user-friendly software tool for determining the appropriateness and reliability of null model tests for your data. Currently, MPower allows you to analyze null model tests of co-occurrence patterns, but future versions will be able to analyze additional types of null model tests. For an introduction to the program, read About MPower.

Null model tests of co-occurrence patterns employ presence-absence data. These data consist of lists of species observed at sites. The sites may be islands, quadrats, lakes, etc (e.g., Krasnov et al 2006, Gotelli and McCabe 2002). The data are often summarized in a presence-absence matrix, in which rows represent species and columns represent sites. If a species was observed at a particular site, 1 is entered in the corresponding cell of the matrix; otherwise 0 is entered. Null model tests of co-occurrence patterns were originally introduced as tools to check whether competition affects co-occurrence patterns of species (Connor and Simberloff 1979). However, they may also be used to check if other interactions are influential, species are distributed "randomly," sites are ecologically equivalent, or species have similar niches (e.g., Gotelli and McCabe 2002).

To use MPower, follow these steps:

  • Open MPower. Check that EcoSim700.exe is in a folder named "EcoSim" next to MPower.
  • Select a null hypothesis that you are interested in testing.
  • Select assumptions that are reasonable for your data set. If no assumptions are reasonable, then leave all assumptions unchecked
  • Choose a hypothesis test that you are considering using.
  • Enter the dimensions of the presence-absence matrix that you wish to analyze.
  • Click "Run." Depending on the options that you select, the analysis may take some time. To display EcoSim, click the "Show EcoSim" box.
  • Examine the results. If the test is suitable for your circumstances, then "*****Test has tolerable Type I error rates.*****" will be displayed in the "Type I Error Rates" section, and "*****Test has adequate power.*****" will be displayed in the "Type II Error Rates" section. Otherwise, warning messages will be displayed.
  • Save the results or click "Close" to return to the initial window.
For additional information about how to use MPower, please see the tutorial and specific reference pages in this help file.


Tutorial

Co-occurrence

This tutorial demonstrates how MPower can be used to choose a null model test for analyzing species co-occurrence patterns. The tutorial will consider a co-occurrence pattern of ants in Virginia (Gotelli and Entsminger 2007, Gotelli and Arnett 2000, Gotelli 2000). The ants were sampled from 25 pitfall traps in a 5m x 5m grid, and in this tutorial, each pitfall trap will represent a site (Figure 1).

Figure 1. Presence-absence matrix used in this tutotial. The matrix contains 1's where species were observed and 0's where they were absent. Matrix from Gotelli and Entsminger (2007).

A salient question about these data is whether interspecific interactions affected the co-occurrence pattern of the ants (Gotelli and Arnett 2000); for instance, if Formica inserta excluded F. subserecia from a portion of the 5m grid. This tutorial shows how to use MPower to assess the appropriateness of a commonly used null model test (Gotelli and Entsminger 2007) for addressing this question.

Analysis 1

  • Open MPower: You should see the following window:

  • Select null and alternative hypotheses: Because the question concerns effects of interspecific interactions, the null hypothesis "No Interactions Between Species" is appropriate. This option is the default, and the corresponding alternative hypothesis is automatically selected. More about null and alternative hypotheses.
  • Select Assumptions: In this analysis, you will assume that all sites and species are equivalent. Later, in Analyses 2 and 3 (below), you will examine the effects of relaxing these assumptions. Site equivalency means that each species is equally likely to occur at each site; for instance, Aphaenogaster treatae is as likely to occur at pitfall trap (1,1) as pitfall trap (5,5). Species equivalency means that at a given site, all species are equally likely to occur; for instance, at pitfall trap (4,1), A. treatae is as likely to occur as F. inserta. To enter these assumptions, check the "Sites Equivalent" and "Species Equivalent" options in the "Assumptions" frame:

    More about assumptions.

  • Select a hypothesis test: One null model test that has been used to analyze these data employs a fixed row, equiprobable column algorithm with C-score (Gotelli and Entsminger 2007). This test is the default option for MPower. More about hypothesis tests.
  • Enter the dimensions of the presence-absence matrix: The presence-absence matrix for the Virginia ant data set has 11 rows and 25 columns. Enter these values in the "Presence-Absence Matrix" frame:

    More about presence-absence matrices.

  • Change the number of iterations: When MPower runs, it simulates matrices and then sends each to EcoSim (Gotelli and Entsminger 2007) to be tested. Each EcoSim test can take a few seconds, so if MPower simulates many matrices, then it can take a long time to run. To allow this tutorial to be completed quickly, we will reduce the number of simulations. However, for non-exploratory analyses, a larger number of simulations should be used to ensure accurate and precise results. To change the number of simulations, click the "Advanced Options" button in the "Analysis" frame. The following window will be displayed:

    Enter "25" for the number of iterations, and click "OK." Click "Yes" to close the warning message that is displayed.

  • Run the analysis: Click the "Run" button in the "Analysis" frame. A progress window will be displayed:

    You can check the "Show EcoSim" option to display EcoSim running in the background. However, this will slow the rate of progress, so uncheck this option when you are finished observing EcoSim.

  • Interpret results: When the calculations are complete a Results window will be displayed:

    The first section of the Results window gives the Type I error rates of the test. In this case, a Type I error occurs if interspecific interactions are indicated when they are actually absent. The "Nominal size" gives the maximum tolerable Type I error rate. Here, that rate is 0.05, which is standard for statistical testing. The "Actual size" gives the actual maximum Type I error rate. This value is close to 0.05, so the test will incorrectly suggest interactions at about the rate that we want it to. The next, Type II error rates section, gives measures of how often the null hypothesis will be rejected when it is false; how often interactions will be suggested when they are present. The "Maximum power" is 0.48, so interactions will be indicated correctly as much as 48% of the time. Ideally this rate could be higher, but it is satisfactory, and overall the test is performing well. However these findings are contingent on the assumptions that sites and species are equivalent. More about results.

    Analysis 2

    In this analysis, we will examine the performance of the test presuming that the assumptions of site and species equivalence are not valid. For instance, slight differences in microclimate might have made ants more likely to occur in some traps than others. Moreover, pitfall trap (4,1) could for instance have been in a location that was more hospitable (e.g., cooler or wetter) to A. treatae than F. inserta. To see how the test behaves when the equivalency assumptions are inappropriate, click "Close" in the lower right corner of the "Results" window. In the Main window that is subsequently displayed, uncheck the "Sites Equivalent" and "Species Equivalent" boxes:

    Click "Run" in the "Analysis" frame. When the simulations are complete, a new Results window will be displayed:

    In the Type I error rates section, note that the actual size is now 1. This means that interspecific interactions will be indicated by the test as often as 100% of the time when they are absent. Because the actual size greatly exceeds the nominal size (still 0.05), a non-robustness warning message is displayed. Moreover, in the Type II error rates section, the minimum power (probability of the test correctly suggesting interactions) is now 0. In some circumstances, the test will always fail to detect interactions when they are present, and moreover, it will give false positives more often than true positives. Hence, a warning message of bias is displayed. Both of these warning messages strongly indicate that the test should be avoided.

    Analysis 3

    In this last analysis, we will consider the situation in which sites are equivalent, but species are non-equivalent. Close the Results window. In the Main window that is displayed, check just the "Sites Equivalent" box in the "Assumptions" frame:

    Click "Run" in the "Analysis" frame. The following results will be displayed:

    These results are qualitatively similar to those in Analysis 1. The test has satisfactory Type I and II error rates.

    Conclusion

    Should this null model test be used? The answer depends on whether the sites and species are equivalent. If they are, or even if just sites are equivalent, then the test is certainly applicable. On the other hand, if sites and species are not equivalent, then the test should definitely not be used; in some circumstances, it will always give wrong answers.

    It is worth noting that other tests may behave differently. To examine the behavior of other tests, click "Change" in the "Hypothesis Test" frame of the main window. In the window that is displayed, select a different test:

    Because they take longer to run in EcoSim, other tests may require more time for evaluation than the one examined here. Generally, if species or sites can be assumed equivalent, then it may be possible to find a test that is applicable . However, when both of these assumptions are unjustified, then in most circumstances all EcoSim tests will be inappropriate (Ladau 2007, Ladau 2005). For such cases, a new, robust and uniformly most powerful method is available (Ladau and Schwager 2007, Ladau 2005).


About MPower

What is MPower?

MPower is a user-friendly application which currently runs in conjunction with the EcoSim program (Gotelli and Entsminger 2007), and is used for determining which null model tests are appropriate for analyzing your ecological data. MPower allows you specify the ecological question in which you are interested, assumptions that you can make about your data, attributes of your sample, and null model test that you are considering using. Contingent on these inputs, MPower calculates several standard quantitative measures of the appropriateness of your null model test, including Type I and II error rates, robustness, and bias (Lehmann and Romano 2005, Casella and Berger 2002). These measures indicate whether the null model test should be used, or if a more reliable method should be substituted. MPower is key for ensuring that you draw the most accurate inferences from your data.

Background Information

Many critical hypothesized ecological mechanisms operate at large spatial and temporal scales to affect distribution patterns. When applied to species distribution patterns, to assess the importance of these mechanisms, experimentation may be impractical, unethical, or impossible (Connor and Simberloff 1986). Instead, inferences must be drawn from observational data. For instance, it may be of interest to infer

  • effects of competition from species distribution patterns.
  • effects of competition from species sizes.
  • ecological and evolutionary constraints from regressions of species-level traits (Gotelli and Graves 1996).

Since qualitative or descriptive studies are non-repeatable, and do not link mechanisms to results, a quantifiable explanation is preferrable.While this may seem an obvious point, a good approach is to use a statistical hypothesis test, which can explicitly accommodate the proposed mechanism. A hypothesis test is a rule that for every potentially obesrvable set of data prescribes one of two actions: conclude that the hypothesized mechanism is occurring (reject the null hypothesis) or that there is insufficient evidence to infer the mechanism (fail to reject the null hypothesis). A given hypothesis test will always yield the same conclusions regardless of who uses it. Moreover, the rate at which a hypothesis test commits errors is quantifiable (Lehmann and Romano 2005, Chernoff and Moses 1967).

Null model tests comprise a particularly widely used class of hypothesis test in ecology, and have been used to address all of the aforementioned questions and many others (Gotelli and Graves 1996). However, numerous null model tests exist to address the same questions, but often yield conflicting conclusions when applied to the same data (e.g., Connor and Simberloff 1979, Gilpin and Diamond 1982, Connor and Simberloff 1983), and in addition have unknown error rates. This raises a critical question: which null model tests should be used? Clearly, a null model test should have low error rates (Gotelli 2000). However, null model tests can also have other desirable properties; for instance, they can have low error rates under a broad range of assumptions (robustness), yield correct conclusions at least as often as incorrect conclusions (unbiasedness), and have the lowest error rates possible (optimality). In a general context, a large body of mathematical theory has been developed to rigorously define these properties, provide means for assessing them, and construct desirable methods (Lehmann and Romano 2005, Casella and Berger 2002). MPower implements the mathematical theory to assess the error rates, robustness, bias, and optimality of commonly used null model tests in ecology, contingent upon the data set that is being analyzed and the inferences that are being drawn.

How MPower Works

To make calculations, MPower simulates data sets using the null hypothesis, assumptions, and data attributes that you input. Some of these data sets are simulated assuming that the null hypothesis is true, while others are simulated assuming that it is false. Each simulated data set is sent to EcoSim (Gotelli and Entsminger 2007), a widely used application for conducting null model tests. MPower directs EcoSim to perform the hypothesis test that you selected, and it records the result that EcoSim yields - i.e., to reject, or fail to reject the null hypothesis. MPower records the frequency with which the null hypothesis is rejected when it is true (Type I error rate) and is not rejected when it is false (Type II error rate). These frequencies are used to calculate the size, robustness, power, and bias of your hypothesis test.


Uses of MPower

Do competition, facilitation, predation, and other ecological processes affect species co-occurrence patterns, body sizes, and other species-level traits? MPower is a tool to find a statistical method for making the most reliable inferences from your data. With MPower, you can evaluate an array of statistical methods using widely accepted mathematical criteria of appropriateness and reliability, and you can determine appropriateness and reliability contingent on the ecological process, assumptions, and data attributes that you select.


MPower and EcoSim

Differences

EcoSim (Gotelli and Entsminger 2007) is a popular Windows-based application for conducting null model tests of species interactions. Users input data into EcoSim and select a null model test which they wish to perform. EcoSim then conducts the test by running simulations, and returns a p-value and other outputs summarizing the results of the test.

EcoSim offers an array of tests, many of which will yield conflicting results when applied to the same data (Gotelli and Entsminger 2007). Which test is most appropriate depends on the null hypothesis that is being tested, the assumptions that can be made, and attributes of the data set (Lehmann and Romano 2005). MPower is a tool for selecting which EcoSim test to use. MPower applies rigorous mathematical criteria to assess whether a test is appropriate and whether it will yield reliable conclusions. Unlike EcoSim, MPower will not analyze your data; rather it is a tool to help you find an appropriate method for conducting your analysis. MPower and EcoSim are complementary software tools, which when used together can allow strong inferences about ecological processes from observational data.

Interface

MPower was developed independently from EcoSim. Nonetheless, you may notice that when you conduct an analysis using MPower, EcoSim is running in the background on your computer. This is because in order to assess the reliability of a null model test, MPower simulates data sets and sends them to EcoSim for testing. MPower then obtains the results of the test from EcoSim, which it uses for its measurements of reliability. MPower interfaces with EcoSim by sending and receiving windows messages.


Null and Alternative Hypotheses

The appropriateness and reliability of null model tests depend on the inferences that are being drawn from them. For instance, a significant result might lead to the conclusion that species are "non-randomly" distributed, interactions affect the co-occurrence pattern of species, or sites differ in habitability (Gotelli and McCabe 2002). The choice of inference determines what constitutes an error, and hence what it means for a test to be reliable. MPower offers three options, which are stated as null and alternative hypotheses. The null and alternative hypotheses give the inferences that are drawn when you obtain a non-significant and significant result, respectively, and they are as follows:

Species Interactions

  • Null Hypothesis: No Interactions Between Species. This null hypothesis posits that at a given site, species occur independently. For instance, if two species can occur at an island, then the probability of species A occurring there is the same regardless of whether species B is already there.
  • Alternative Hypothesis: Interactions Between Species. This alternative hypothesis posits that at a given site, species occur dependently. For instance, if competition affects the co-occurrence pattern, then species A might be less likely to occur if species B is present.

Heterogeneity of Sites

  • Null Hypothesis: Sites Equivalent. This null hypothesis posits that each species is equally likely to occur at all sites. Such a situation might arise if sites are uniform and equally accessible. Note that in such an environment, different species may have different probabilities of occurring.
  • Alternative Hypothesis: Sites Non-equivalent. This alternative hypothesis posits that species have different probabilities of occurring at different sites. Such a situation might arise if sites differ in microclimates, or some sites are more accessible than others.

Heterogeneity of Species

  • Null Hypothesis: Species Equivalent. This null hypothesis posits that at a given site, all species are equally likely to occur. Such a situation might arise if all species have similar dispersal abilities and niche requirements, so that if a site is accessible and hospitable to one species, then it is accessible and hospitable to all species. This null hypothesis differs from the previous null hypothesis in that sites may differ. For instance, all species might be more likely to occur at site 1 than site 2.
  • Alternative Hypothesis: Species Non-equivalent. This alternative hypothesis posits that species may have different probabilities of occurring at each site. For instance, because a site might be in a arid location, Species A might be more likely to occur there than species B.

Precise mathematical definitions of the null and alternative hypotheses are given in Mathematical Details.


Assumptions

The appropriateness and reliability of any hypothesis test depend on which assumptions are reasonable. As an example of this, if assumptions of normality and independence are met, then a Student's t-test is an appropriate and optimal test of whether two means differ. When the assumptions are invalid but others are met, different, non-parametric tests are appropriate (Zar 1999).

Likewise, the reliability of null model tests depends on which assumptions are appropriate (Ladau 2007). MPower allows you to specify three particularly germane assumptions:
  • Interactions Between Species: If species interact, then at a given site the presence of species is assumed to change the probability of other species occurring there. For instance, species A is assumed to be less likely to occur if species B is present. You can select 0%, 50%, or 100% of species interacting. If the box next to "Interactions Between Species" is left unchecked, then no assumption is made about species interactions. It is best to leave the box unchecked unless you know or can make very good assumptions about what proportion of species are interacting.
  • Sites Equivalent: If the box next to "Sites Equivalent" is checked, then each species is assumed equally likely to occur at all sites (different species may have different probabilities of occurring, though). Such a situation might arise if sites are uniform and equally accessible. Leaving the box unchecked means that species may have different probabilities of occurring at different sites. It is best to leave the box unchecked unless you are certain that sites have identical environments and are uniformally accessible.
  • Species Equivalent: If the box next to "Species Equivalent" is checked, then all species are assumed equally likely to occur at each site (they may have different probabilities of occurring at different sites, however). Such a situation might arise if all species have similar dispersal abilities and niche requirements, so that if a site is accessible and hospitable to one species, then it is accessible and hospitable to all species. Leaving the box unchecked means that different species can have different probabilities of occurring at the same site. Leaving the box unchecked is recommended unless you know that all species have identical dispersal abilities and niche requirements.
In general, if no assumptions are made, then it is very likely that all tests in EcoSim will be unreliable, while if more assumptions are made, then more tests will be reliable. That said, some tests - particularly the ones that fix row or column totals - may require fewer assumptions than other tests (Ladau 2007). Precise definitions of the assumptions are given in Mathematical Details.


Hypothesis Test

All null model tests are hypothesis tests. For every possible set of observed data, they are rules that prescribe an action of either rejecting or not rejecting the null hypothesis (Lehmann and Romano 2005). Numerous, often complex, methods have been developed to define these rules, many of which are implemented in EcoSim (Gotelli and Entsminger 2007). In EcoSim, to choose a method the user usually selects a row and column constraint; co-occurrence index; iterations option; fixed-fixed randomization algorithm; and degenerate matrix option. MPower allows you to evaluate every test in the Co-occurrence module of EcoSim, and future versions will allow evaluation of tests from other EcoSim modules.


Presence-Absence Matrix

The appropriateness of any hypothesis test can depend on attributes of the sample that is being analyzed. For instance, most ANOVAs require a minimal sample size, below which the test will be incapable of giving significant results (Zar 1999). Likewise, the appropriateness and reliability of null model tests of co-occurrence patterns can depend on attributes of the presence-absence matrix; particularly its dimensions (Ladau 2007). Hence, MPower allows you to input the dimensions of the presence-absence matrix that you are analyzing. In general, small matrices (fewer than 7 rows and columns) may have low power. However, you should assess appropriateness and reliability for the matrix that you are analyzing rather than infer them from a similarly-sized matrix; they can vary unpredictably with matrix size.


EcoSim Options

The EcoSim options window allows you to select the null model test of co-occurrence patterns that you wish to analyze. Generally speaking, null model tests of co-occurrence patterns that fix row or column totals are most likely to be appropriate and reliable (Ladau 2007). Intuitive justifications for various tests can be found elsewhere (e.g., Gotelli and Entsminger 2007, Gotelli 2000), and these may serve as a rough guide for selecting tests to evaluate in MPower. To ultimately select which null model test of co-occurrence patterns you will use, you should analyze its performance in MPower conditional on the null hypothesis that you are testing, assumptions that you can make, and data that you are analyzing.


Results

When MPower completes an analysis, it displays a Results window. The Results window allows you to assess whether your null model test is appropriate for analyzing your data given the assumptions and null hypothesis that you selected. The Results window should be largely self-explanatory. This page adds some important details:

  • Type I Error Rates: Two messages can be displayed at the bottom of this section:
    1. *****Warning: Test has high Type I error rates. The null hypothesis will be rejected as much as ----% of the time when it is true.*****:
    This message indicates that the null model test of co-occurrence patterns will give false positives at an intolerably high rate. For instance, if the null hypothesis was "Sites Equivalent" and you observed a significant result (i.e., p < 0.05), you could not tell whether this was because sites were really non-equivalent or because the test made an error. This message is displayed whenever the actual size of the test is 0.15 or greater. When you get this message, you should not use a test.
2. *****Test has tolerable Type I error rates.*****
This message indicates that the test is performing well in terms of Type I errors.

  • Type II Error Rates: Three messages can be displayed at the bottom of this section
    1. *****Warning: Test is biased. The null hypothesis will be rejected more often when it is true than when it is false.*****:
    This message is displayed whenever the minimum power is no greater than half of the actual size of the test. It indicates that the test may sometimes give false negatives more often than true negatives. For instance, it might indicate an absence of interspecific interactions more often when species are not interacting than when they actually are interacting. Needless to say, it is undesirable for a null model test to have this property, and such a test should generally be avoided.
2. *****Warning: Test has low power. The null hypothesis will be rejected no more than ----% of the time when it is false.*****:
This message is displayed when the maximum power of the test is less than 0.15. It indicates that the test lacks sensitivity. For instance, it might be very unlikely to indicate interspecific interactions when they are present. If you would like to be able to infer a lack of a process from a high p-value, then tests with low power should be avoided.

3. *****Test has adequate power.*****:
This message indicates that the test is unbiased, has good sensitivity, and has low Type II error rates.

  • Null Hypothesis, Assumptions, Hypothesis Test, Conditions: These sections list the inputs that were initially selected.
  • Raw Results: This section has three columns. The first column lists the probability measure at which the power function was evaluated. The values are ordered pairs, in which the first number gives the proportion of species interacting (1 = 0%, 2 = 50%, 3 = 100%) and the second number gives the matrix of occurrence probabilities (P; defined in Mathematical Details). The second column lists whether the probability measure is an element of the selected null hypothesis. The last column gives the value of the power function; i.e., the probability of rejecting the null hypothesis. A complete discussion of these terms is given in Mathematical Details.


Overview

Overview of Mathematical Details

MPower evaluates null model tests of co-occurrence patterns using a rigorous, Neyman-Pearson hypothesis testing theory framework. The tests are evaluated under statistical models of the general form given in Ladau (2007). Briefly, the probability measures in the models are on the set of all presence absence matrices with m rows and n columns, where m and n are the observed number of species and sites. The probability measures are all defined so that the probability of species i occurring at site j is independent of species k occurring at site l, where j and l are distinct. The measures can be indexed by a two parameters. The first parameter, P, is a m by n matrix whose i,jth entry gives the probability of species i occurring at site j. The second parameter, θ, is a matrix that gives the dependence between the occurrence of each pair of species at each site.

When you specify assumptions in MPower, you are constraining the statistical model. For instance, if you specify that sites are equivalent, then MPower considers the model that contains only probability measures such that pij = pik, where pij and pik are the i,jth and i,kth entries in P. Likewise, when you specify the null hypothesis, you are specifying a subset of the model. For instance, the null hypothesis of species equivalence consists of the measures in the model such that pij = pkj for all i and k. The precise definitions of all models, null hypotheses, and alternative hypotheses used by MPower are given in Assumptions and Models and Null and Alternative Hypotheses.

To assess robustness, bias, and power, MPower calculates the value of the power function on a subset of probability measures in the model. MPower can evaluate the power function over a maximal set of 36 measures. If you select assumptions, then some of these 36 measures are no longer elements of the model and MPower will not evaluate the power function over them. Which measures are elements of the null hypothesis is determined by the null hypothesis that you select.

The 36 measures that MPower examines represent a diverse sample from each model, and they will usually lead to correct conclusions. Nonetheless, because they constitute a sample (examing more measures is very time-consuming, and examining every measure is impossible because there is an infinite number of them), it is possible that unexamined measures exist in the null hypothesis that would increase the maximum Type I error rates, and therefore the size of the test. For this reason, results stating adequate Type I error rates could be misleading: a test could have an actual size greater than stated. Likewise, it is possible that unexamined measures in the alternative hypothesis could lead to a conclusion of biasedness rather than unbiasedness, or of sufficient rather than insufficient power. These concerns should not generally affect results because of the breadth of the the 36 measures, but they should be kept in mind when interpreting results. MPower also offers the ability to add additional measures by simple modifications to the Visual Basic 6.0 source code. Please contact the Joshua Ladau (jladau@santafe.edu) for further details if you are interested in making such modifications.


Null Hypotheses

Null and Alternative Hypotheses

The null hypotheses used in MPower are defined as follows:

  • No Interactions Between Species: Let Xij be a random variable equal to 1 if species i is present at site j, and 0 otherwise. This null hypothesis is the set of probability measures in the model such that P(Xij = 1 | Xkj = 1) = P(Xij = 1 | Xkj = 0) for all distinct i and k. In other words, species i is equally likely to occur regardless of whether species k is present.
  • Sites Equivalent: This null hypothesis is the set of probability measures in the model such that pij = pik where pij and pik are the i,jth and i,kth entries in P.
  • Species Equivalent: This null hypothesis is the set of probability measures in the model such that pij = pkj where pij and pkj are the i,jth and k,jth entries in P.
For each null hypothesis, the alternative hypothesis is the complement of the null hypothesis over the model.


Models (Assumptions)

Assumptions and Models

In MPower, making the following assumptions imposes the following constraints on the model:

  • Interactions Between Species: : Let Xij be a random variable equal to 1 if species i is present at site j, and 0 otherwise, and define θijk = P(Xij = 1 | Xkj = 1) / P(Xij = 1 | Xkj = 0). For some values of P, sufficiently large values of θijk lead to contradictions; for instance that P(Xij = 1)>1. Let θ*ijk be the maximum of θijk given P. If 100% of species interact, the model contains only probability measures P such that for i even and k odd, θijk = min{2, θ*ijk} and for all other i and k, θijk = 1. If 50% of species interact, then θijk = min{2, θ*ijk} for only the first half of the species (i even and k odd); for the remaining species θijk = 1. If 0% of species interact, then θijk = 1 for all pairs of species.
  • Sites Equivalent: The model contains only probability measures such that pij = pik where pij and pik are the i,jth and i,kth entries in P.
  • Species Equivalent: The model contains only probability measures such that pij = pkj where pij and pkj are the i,jth and k,jth entries in P.


Power Function

Domain of Power Function

MPower evaluates the power function over a subset of the model. The subset contains the probability measures in the model that are indexed by the following 12 values of P:

Figure 1. Values of P over which the power function is evaluated in MPower. The variables m and n give the number of rows and columns in the observed presence-absence matrix, respectively. [] denotes the floor function; e.g., [2.8] = 2. Shading indicates the values of the occurrence probabilities in P. Hence, P1 means that all species have probability of ~0.1 of occurring at each site, while P6 means that all species have probability ~0.1 of occurring at sites 1 to [n/2] , and probability ~0.3 at the remaining sites.

The probability measures are also those in which 0%, 50%, or 100% of species interact, as described in the Assumptions and Models section. Hence, MPower evaluates the power function over a maximum of 12 x 3 = 36 probability measures.


Alternative Hypothesis

Definition: An alternative hypothesis is a subset of a statistical model. The alternative and null hypotheses partition the statistical model (Bickel et al 1993).


Bias

Definition: A test is biased if its power function attains a greater value for some probability measure in the null hypothesis than for some probability measure in the alternative hypothesis (Lehmann and Romano 2005).


Hypothesis Test

Definition: A hypothesis test is a function on the set of possible data into an action space containing two elements, reject the null hypothesis and fail to reject the null hypothesis (Lehmann and Romano 2005).


Null Hypothesis

Definition: A null hypothesis is a subset of a statistical model. The null and alternative partition the statistical model (Bickel et al 1993).


Power

Definition: For a given probability measure in the alternative hypothesis, power is the probability of rejecting the null hypothesis (Lehmann and Romano 2005).


Power Function

Definition: The power function of a hypothesis test is defined on the statistical model. For each probability measure in the statistical model, the power function gives the probability of rejecting the null hypothesis. For probability measures that are elements of the null hypothesis, the power function gives the Type I error rate, while for measures that are elements of the alternative hypothesis, the power function gives the power (Lehmann and Romano 2005, Casella and Berger 2002).


Robustness

Definition: Many definitions have been proposed for robustness (Lehmann and Romano 2005, Bradley 1968). Here, a test is defined as robust under a given statistical model if its actual size is no more than 3 times the nominal size.


Size

Definition: The size of a test is the maximum value of the power function over the null hypothesis (Lehmann and Romano 2005, Casella and Berger 2002).


Assumptions/Model

Statistical Model

Definition: A statistical model is a class of probability measures all defined on the same field (Bickel et al 1993).


Type I Error

Definition: A Type I error occurs if a hypothesis test yields "reject the null hypothesis" when the null hypothesis is true (Lehmann and Romano 2005, Casella and Berger 2002).


Type II Error

Definition: A Type II error occurs if a hypothesis test yields "fail to reject the null hypothesis" when the alternative hypothesis is false (Lehmann and Romano 2005, Casella and Berger 2002).


Error Messages

This section lists the possible error messages that MPower can generate, their causes, and methods to resolve them.

Error 01

  • Message: "Error 01: At least 1 iteration required."
  • Cause: A non-numeric value or number smaller than 1 was entered in the "Number of Iterations" text box in the "Iterations" frame of the EcoSim Options window.
  • Resolution: Enter a number larger than 0 in "Number of Iterations" text box in the "Iterations" frame of the EcoSim Options window.

Error 02

  • Message: "Error 02: EcoSim700.exe not found."
  • Cause: MPower could not find EcoSim700.exe, which it requires to perform analyses.
  • Resolution: Place EcoSim700.exe in a folder in the same directory as the MPower executable. The the folder should be titled "EcoSim."

Error 03

  • Message: "Error 03: invalid file name"
  • Cause: An error occurred while saving results.
  • Resolution: Check that the file to which results are being saved follows standard Windows naming conventions and that it is not being used by another program.

Error 04

  • Message: "Error 04: Matrix must have at least 2 columns."
  • Cause: A non-numeric value or number smaller than 2 was entered in the "Columns (Number of Sites)" text box in the "Presence-Absence Matrix" frame of the Main window.
  • Resolution: Enter a number larger than 1 in the "Columns (Number of Sites)" text box in the "Presence-Absence Matrix" frame of the Main window.

Error 05

  • Message: "Error 05: Matrix must have at least 2 rows."
  • Cause: A non-numeric value or number smaller than 2 was entered in the "Rows (Number of Species)" text box in the "Presence-Absence Matrix" frame of the Main window.
  • Resolution: Enter a number larger than 1 in the "Rows (Number of Species)" text box in the "Presence-Absence Matrix" frame of the Main window.

Error 06

  • Message: "Error 06: Number of iterations cannot exceed 50000."
  • Cause: The number of iterations for the hypothesis test was set to a number greater than 50000, the maximum allowable by EcoSim.
  • Resolution: Reduce the number of iterations entered in the "Number of Iterations" text box in the "Iterations" frame of the EcoSim Options window.

Error 07

  • Message: "Error 07: Number of iterations must be an integer greater than 0."
  • Cause: The number of MPower iterations was set to a non-numeric value or number less than 1 in the Advanced Options window.
  • Resolution: Enter a number greater than 0 in the "Number of Iterations" text box in the "Simulations" frame of the Advanced Options window.

Error 08

  • Message: "Error 08: Random seed must be nonnegative."
  • Cause: The random seed for the hypothesis test was set to a negative number. EcoSim accepts only positive values.
  • Resolution: Enter a positive random seed in the "Random Number Seed" text box in the "Iterations" frame of the EcoSim Options window.

Error 09

  • Message: "Warning: Simulating with fewer than 100 iterations may yield unreliable results. Continue? (Error 09)"
  • Cause: The number of MPower iterations was set to a number less than 100 in the Advanced Options window. Simulating with fewer than 100 iterations can yield imprecise and inaccurate results, and is only recommended for initial, exploratory analyses.
  • Resolution: If you are performing an exploratory analysis, then click "Yes." Otherwise, click "No" and increase the number of iterations in the "Number of Iterations" text box in the "Simulations" frame of the Advanced Options window.


Other Problems

Other Issues

  • Issue: The progress window states that calculations will take a very long time.
  • Cause: MPower makes calculations by simulating presence-absence matrices and sending them to EcoSim to be tested. Although simulating matrices is very fast, each EcoSim test can take a non-trivial amount of time, dependent upon the hypothesis test that is selected.
  • Resolution: This issue can be resolved in three ways. First, the number of matrices that MPower simulates (and hence EcoSim analyzes) can be reduced by clicking the "Advanced Options" button on the Main window and reducing the number of iterations. Second, some hypothesis tests run faster than others in EcoSim. To change the hypothesis test, click the "Change" button in the "Hypothesis Test" frame of the Main window. Third, the number of EcoSim iterations can be reduced.
  • Issue: MPower slows the computer down or causes it to crash.
  • Cause: When an analysis is running in MPower, EcoSim is also running in the background. Although both programs minimize CPU and memory usage, their combined demands may be excessive on some systems.
  • Resolution: If other applications are also running, close them. If the problem persists, try running MPower on another computer. MPower should run on any computer with at least 256 MB of RAM and a processor speed of at least 700 MHz.


References

Bickel, P.J., Klaassen, C.A., Ritov, Y., and Wellner, J.A. (1993) Efficient and Adaptive Estimation for Semiparametric Models, The Johns Hopkins University Press, Baltimore.

Bradley, J.V. (1968) Distribution-Free Statistical Tests, Prentice-Hall, New Jersey.

Casella, G. and Berger, R.L. (2002) Statistical Inference: Second Edition, Duxbury, Pacific Grove.

Chernoff, H. and Moses, L.E. (1967) Elementary Decision Theory, John Wiley and Sons,New York.

Connor, E.F. and Simberloff, D. (1979) The Assembly of Species Communities: Chance or Competition? Ecology, 60, 1132-1140.

Connor, E.F. and Simberloff, D. (1983) Interspecific Competition and Species Co-Occurrence Patterns on Islands: Null Models and the Evaluation of Evidence. Oikos, 41, 455-465.

Connor, E.F. and Simberloff, D. (1986) Competition, scientific method, and null models in ecology. American Scientist, 74, 155-162.

Gilpin, M.E., and Diamond, J.M. (1982) Factors contributing to non-randomness in species Co-occurrences on Islands. Oecologia, 52, 75-84.

Gotelli, N.J. (2000) Null Model Analysis of Species Co-Occurrence Patterns. Ecology, 81, 2606-2621.

Gotelli, N.J. and Arnett, A.E. (2000) Biogeographic effects of red fire ant invasion. Ecology Letters, 3, 257-261.

Gotelli, N.J. and Entsminger, G.L. (2007) EcoSim: Null models software for ecology. Version 7. Acquired Intelligence Inc. & Kesey-Bear. Jericho, VT 05465. http://garyentsminger.com/ecosim.htm.

Gotelli, N.J. and Graves, G.R. (1996) Null Models in Ecology, Smithsonian Institution, Washington.

Gotelli, N.J. and McCabe, D.J. (2002) Species co-occurrence: a meta-analysis of J. M. Diamond's assembly rules model. Ecology, 83, 2091-2096.

Krasnov, B. R., Stanko, M., and Morand, S. (2006) Are ectoparasite communities structured? Species co-occurrence, temporal variation and null models. Journal of Animal Ecology, 75, 1330-1339.

Ladau, J. (2005). Robust Statistical Tests for Detecting the Effects of Interspecific Competition on Ecological Communities. Thesis, Cornell University.

Ladau, J. (2007). Validation of null model tests using Neyman-Pearson hypothesis testing theory. Submitted.

Ladau, J. and Schwager, S.J. (2007). Robust Hypothesis Tests for Independence in Community Assembly. In press, Journal of Mathematical Biology.

Lehmann, E.L., and Romano, J.P. (2005) Testing Statistical Hypotheses: Third Edition, Springer, New York.

Zar, J.H. (1999). Biostatistical Analysis, Prentice Hall, New Jersey.